リジッドボディーが効かない? 独りでジタバタw

 
  リジッドボディーをしようと思いリジッドボディーを適応したら
 何やら警告とエラーが出て、リジッドボディーを適応してくれない・・・
 
  
 // rigidSolver //
 // rigidBody1 //
 // 警告: コネクションを解除できません: ‘rigidSolver.generalForce’ から ‘rigidBody1.generalForce’。
     強制的にコネクションを解除するには、アトリビュートエディタで ‘Allow Disconnection’ アトリビュートを設定
   します。 //
 // エラー: 次のコネクションが生成されませんでした: ‘rigidBody1.generalForce’ -> ‘rigidSolver.generalForce[0]’。 
     ソース ノードはコネクション解除を許可しません。 //
 // 警告: ‘pSphere1.worldMatrix[0]’ のサイクルは要求どおり評価しない可能性があります
    (この警告を無効にするには ‘cycleCheck -e off’ を使用します)。 //
 // 警告: ‘rigidBody_tx.output’ のサイクルは要求どおり評価しない可能性があります
    (この警告を無効にするには ‘cycleCheck -e off’ を使用します)。 // 
 何やら言ってるが、それらしきモノもなく一体何をどうするのん?状態。
 またまたMayaがおかしくなったかな? こういうときはMayaを再起動すると直ることが多い。
 Mayaを触りだしてから、おかしくなったらとりあえず再起動が習慣になっている。(^^;;;;
 
 がしかし、治らない・・・
 因みに不思議なことに? ソフトボディやクロス、パーティクルなどのダイナミクスは問題なく行える。
 なぜリジッドボディーだけが効かない???
 
 
 だーーーー、イロイロ試しても原因つかめず・・メンドクセってなって
 Maya再インスコすっか・・。ってことで再インスコ。
 
 
 ・・・・治らん・・えーーーーーー?!
 なんすか? なんでっすか??!!
 
 
 と、・・まてよ・・Maya再インスコしても外部プラグインとかの設定って生きてるんだよね。 まさか?
 で、思い当たる外部プラグインが・・
  
 Pulldownit
 
 これってリジッドボディー関連のプラグインで物体の破壊などをサポートしてくれる良プラグインなんすが、
 これのフリー版を使用して ちょい前に試しに作ったシーンがあるのでロードしてシーンでアニメーションを
 再生してみたら問題なく動いてる。
 
 ?!!
 
 ってことで
 
  
 
 プラグインマネージャ開くと当然?のごとくロードにチェック入れてます。
 このチェック外してMaya再起動!
 
 Mayaのデフォルトのリジッドボディーを任意のオブジェクトに適応! 
 問題なくエラーも警告も一切出ず適応できましたやん!!
 
 
 
 つまりバッティングしてたってこと?
 ってことで、このプラグインとMaya標準のリジッドボディーは併用出来ません。(多分・・自信なしw)
 と、ソフトボディーやクロス、パーティクル等の他のダイナミクスとはバッティングしていないようです。
 
 しかしこんな重要なこと断ってないはずないですよね?
 オイラまた見逃してたのかな? そもそも英語には目を通さないから。(アカンやん・・・orz)
 
 
広告
カテゴリー: Maya パーマリンク

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト /  変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト /  変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト /  変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト /  変更 )

%s と連携中